site wide instability

Incident Report for SimplyWallSt

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 13:35 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2026 - 13:21 AEDT

Investigating

We are currently investigating this issue.
Posted Feb 20, 2026 - 12:52 AEDT
This incident affected: Stock Reports, Dashboard, Portfolio, Watchlist, Community, Discover, Screener, Simply Wall St News, and Billing.