Partial outage accessing SWS platform
Incident Report for SimplyWallSt
Resolved
This incident has been resolved
Posted May 06, 2021 - 22:07 AEST
Investigating
We are currently investigating this issue
Posted May 06, 2021 - 21:44 AEST
This incident affected: Website and API.