SWS Platform service degraded
Incident Report for SimplyWallSt
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 20:59 AEDT
Investigating
Some pages will take longer to display or fail. Team is currently investigating the issue
Posted Nov 25, 2022 - 20:13 AEDT
This incident affected: Website and API.