Some company logos not appearing on company report
Incident Report for SimplyWallSt
Resolved
This incident has been resolved.
Posted Mar 21, 2022 - 14:38 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2022 - 12:45 AEDT
Investigating
We are currently investigating this issue.
Posted Mar 21, 2022 - 12:31 AEDT
This incident affected: Website.